Zrozumieć jej działanie: funkcja JEŻELI

JEŻELI – ta funkcja programu Excel należy do najbardziej popularnych i najczęściej używanych. Jej funkcjonowanie polega na sprawdzaniu wartości w wybranych komórkach i, w zależności od wyniku, wypisywaniu odpowiednich komunikatów. Często jednak przysparza użytkownikom wielu trudności, szczególnie w bardziej skomplikowanych przypadkach. Postaramy się dziś przybliżyć sposób jej działania.


Podstawowe zastosowanie

Zacznijmy od podstawowych wiadomości. JEŻELI należy do grupy funkcji logicznych, czyli takich, które testują pewne warunki i na tej podstawie wyświetlają odpowiedni wynik. Funkcja ta może generować tylko dwa wyniki: pierwszy otrzymamy, jeśli wynik jest prawdziwy, a drugi — jeśli wynik jest fałszywy. Jej składnia wygląda następująco:

=JEŻELI(test_logiczny; [wartość_jeżeli_prawda]; [wartość_jeżeli_fałsz])
  • test_logiczny – kryterium/pytanie/porównanie dwóch wartości, na podstawie którego funkcja JEŻELI zwróci jedną z wartości: PRAWDA lub FAŁSZ,
  • wartość_jeżeli_prawda, wartość_jeżeli_fałsz – wartości, jakie wyświetli formuła po sprawdzeniu warunku z pierwszego argumentu: w przypadku jego spełnienia (PRAWDA) lub niespełnienia (FAŁSZ)

W praktyce wygląda to następująco. Załóżmy, że w kolumnie C znajdują się kwoty wartości sprzedaży poszczególnych sprzedawców. Na ich podstawie przyznawana jest premia w taki sposób, że aby ją otrzymać, trzeba przekroczyć próg sprzedaży 10 000 zł. W kolumnie D chcemy sprawdzić, czy premia ta przysługuje poszczególnym sprzedawcom i na tej podstawie wyświetlić komunikat: PREMIA lub BRAK. Formuła ta będzie wyglądała następująco:

=JEŻELI(C2>$G$1;"PREMIA";"BRAK")

Rysunek 1. Przykład zastosowania funkcji JEŻELI.

Wskazówka: Zanim rozpoczniesz tworzenie instrukcji z funkcją JEŻELI, określ, jaki wynik chcesz osiągnąć i jakie wartości chcesz ze sobą porównać. Ułatwi to późniejsze wprowadzanie poszczególnych argumentów funkcji.


Zagnieżdżanie funkcji

Innym często spotykanym zastosowaniem funkcji JEŻELI jest jej forma zagnieżdżona. Co to oznacza? Otóż w przypadku bardziej złożonych scenariuszy może zaistnieć konieczność połączenia wielu funkcji w jednej formule, czyli takiego skonstruowania formuły, że jednym z argumentów funkcji JEŻELI jest kolejna funkcja JEŻELI. Rozwiązanie to sprawdza się np. w sytuacji, gdy trzeba przydzielić wysokość premii zależnie od wartości przedziału, w jakim znajduje się wynik sprzedaży. Przykładowa formuła wygląda następująco:

=JEŻELI(C2>10000;1000;JEŻELI(C2>5000;500;0))

Jej działanie polega na tym, że sprawdzamy wartość sprzedaży w komórce C2 i na tej podstawie przydzielamy wysokość premii: dla wartości sprzedaży powyżej 10 000 zł premia wynosi 1000 zł, dla wartości sprzedaży powyżej 5000 zł przysługuje premia o wysokości 500 zł, natomiast sprzedawcy z pozostałymi kwotami sprzedaży (większymi i równymi 5000 zł) nie otrzymują premii (jej wysokość jest równa 0 zł). Poniżej na rysunku znajduje się formułami, gdzie zamiast konkretnych kwot są podane adresy komórek z tymi kwotami.

Rysunek 2. Formuła z zagnieżdżoną funkcją JEŻELI.

Wskazówka: W przypadku tworzenia złożonych (zagnieżdżonych) instrukcji JEŻELI ważne jest, by sprawdzić, czy zapisane w formule instrukcje odpowiadają logicznemu ciągowi zdarzeń. W przeciwnym wypadku działanie formuły nie będzie zgodne z oczekiwaniami.


Łączenie warunków

Często podczas tworzenia formuł z użyciem JEŻELI zachodzi potrzeba połączenia kilku warunków. W tym miejscu z pomocą przychodzą funkcje ORAZ i LUB:

  • ORAZ – umożliwia połączenie przynajmniej dwóch warunków w taki sposób, że oba (wszystkie) warunki muszą być prawdziwe
=JEŻELI(ORAZ(B2>80%;C2>75%); "stypendium"; "brak")

Powyższa formuła sprawdza, czy danemu studentowi przysługuje stypendium. Aby tak było, Jego wynik z egzaminu 1 musi przekroczyć 80%, a z egzaminu 2 –75%. W przeciwnym wypadku w komórce wyświetla się komunikat „brak”.

Rysunek 3. Wykorzystanie funkcji ORAZ razem z funkcją JEŻELI.

  • LUB – umożliwia połączenie przynajmniej dwóch warunków w taki sposób, że przynajmniej jeden warunek musi być prawdziwy:
=JEŻELI(LUB(A2="śliwka";A2="jabłko");"owoce";"inne")

W powyższej formule sprawdzane jest, czy dany produkt należy do kategorii „owoce”. Aby formuła ta była prawdziwa, w komórce A2 musi znajdować się nazwa „jabłko” albo „śliwka”.

Rysunek 4. Wykorzystanie funkcji LUB razem z JEŻELI.

Wskazówka: Ważnym elementem odpowiedniego stosowania funkcji ORAZ i LUB jest zrozumienie różnicy w ich logice. Otóż w przypadku ORAZ muszą być spełnione wszystkie warunki naraz, natomiast w przypadku LUB – wystarczy spełnienie przynajmniej jednego warunku.

200 godzin szkoleń online z Excela

Wypróbuj platformę szkoleniową calculatic.pl i obejrzyj ponad 1300 filmów